Installation

Web3 required

DEX.AG SDK interacts with many different decentralized exchanges (DEXs) that are built on the Ethereum blockchain. Our SDK requires that your application use web3.js to connect to Ethereum. Read the web3 docs to learn more.

Your users will also need to use a web3-compatible browser. The MetaMask extension (available for Chrome, Firefox, Opera) or Brave Browser are the most popular ways to connect to web3 for Desktop. Some Web3-compatible mobile browsers include Trust Wallet and Coinbase Wallet, and Opera.

Install from NPM‚Äč

$ npm install dexag-sdk

Constructor

Create an instance of DEX.AG with the default web3 browser provider.

import {DEXAG} from 'dexag-sdk'
const sdk = DEXAG.fromProvider(window.ethereum);